Cloudflare Migration Trouble
Incident Report for ReadMe
Resolved
The Cloudflare migration has been postponed until Q1 2020. When we're ready to reschedule the migration we'll post it on status.readme.io
Posted Dec 20, 2019 - 16:10 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 19, 2019 - 18:52 PST
Monitoring
We're communicating with Cloudflare Enterprise emergency support to review our incident and ensure we have configuration settings that will not compromise any ReadMe customers.

We will not be moving forward until we have guaranteed functionality on every customer domain.
Posted Dec 19, 2019 - 11:49 PST
Identified
Customers with large amounts of traffic experienced "ERR_TOO_MANY_REDIRECTS" upon migration due to HTTP requests redirecting to HTTPS.

Changes made:
• Removing the HTTPS redirects from the origin
• Establishing an Always Use HTTPS page rule to avoid a redirect loop

We are standing by to receive confirmation from Cloudflare about the fix before moving forward.
Posted Dec 19, 2019 - 11:14 PST
Investigating
Our scheduled migration to Cloudflare SSL services went smoothly for some ReadMe projects but caused other ReadMe projects to go down. We have rolled back the migration and are actively investigating the issue.

The downtime experienced by the affected domains was about 15-20 minutes
Posted Dec 19, 2019 - 10:54 PST
This incident affected: ReadMe Hubs.