Slow Load Times and Timeout Errors
Incident Report for ReadMe
Resolved
Last Tuesday, we were getting errors in our logs due to Let’s Encrypt deprecating v1 of their API. We had to fairly quickly migrate to v2 by upgrading some of the core libraries of our infrastructure.

Upgrading that one library caused lots of instability and kept making the servers crash, meaning we had to upgrade the version of the server we’re using as well. This was on Wednesday.

This caused more stability but then we started hitting lots of rate limits and also meant we were getting lots of “JWS Verification Errors” in our logs. This seemed to stabilize towards end of day Wednesday.

Next week we're planning a migration of our SSL infrastructure to another provider, so any of these issues will be fully resolved then. If you're still having problems, you can CNAME directly to cname.readme.io in the meantime.
Posted Dec 05, 2019 - 13:24 PST
Monitoring
The majority of affected ReadMe projects are back up, a post-mortem will be posted on Monday.

If your docs are still down, as a quick fix please change the CNAME of your domain from ssl.readmessl.com to cname.readme.io and leave a message for our Support team.

We'll reach out early next week with steps for a more permanent fix.
Posted Nov 27, 2019 - 17:48 PST
Investigating
We have received reports that some ReadMe developer hubs are seeing slow load times and timeout errors. Our engineering team is investigating the problem now that appear to be affecting our SSL certificate renewal process.
Posted Nov 27, 2019 - 11:53 PST
This incident affected: ReadMe Hubs.