Slow performance on ReadMe hubs and dashboard

Incident Report for ReadMe

Resolved

After monitoring, performance has improved significantly
Posted Feb 23, 2025 - 21:02 PST

Investigating

We're investigating slow performance on both the dashboard and hub
Posted Feb 20, 2025 - 11:49 PST
This incident affected: ReadMe Hubs and Admin Dashboard.