Slow performance across customer hubs

Incident Report for ReadMe

Resolved

This incident has been resolved.
Posted May 26, 2026 - 20:54 PDT

Monitoring

We have identified and quickly fixed the issue and are currently investigating a more thorough fix
Posted May 26, 2026 - 10:49 PDT

Investigating

We are experiencing slow performance across customer hubs
Posted May 26, 2026 - 10:41 PDT
This incident affected: ReadMe Hubs and Admin Dashboard.