Spike in 500 errors
Incident Report for ReadMe
Postmortem

Hey folks! We wanted to provide you with an update on the outage we experienced earlier today. Here’s a recap of what happened:

  • At 8:26am PST, server errors for all of our critical applications (which run on Heroku’s platform) started cropping up. Within a few minutes, nearly every application running on Heroku was experiencing a full outage. This includes the applications powering ReadMe dashboards, developer hubs, and Developer Metrics platforms.
  • We were paged about the incident at 8:29am PST and were actively responding by 8:30am PST. We started providing updates on the incident within a few minutes of the outage, at approximately 8:34 PST.
  • We confirmed that the upstream provider causing the issues was Heroku (thanks in large part to the Twitter chatter on the topic)! Heroku also eventually confirmed the issue at 8:53am PST.
  • Our service recovered fully at 9:14am PST.

We sincerely apologize again for the downtime, folks. If you have any other questions or are still experiencing troubles, please get in touch at support@readme.io!

Posted Feb 24, 2022 - 15:23 PST

Resolved
Our service recovered at 9:14am Pacific Time and has been fully operational since then. Please let us know if you continue to see any issues.
Posted Feb 24, 2022 - 09:49 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 24, 2022 - 09:27 PST
Monitoring
We're seeing early signs of recovery.
Posted Feb 24, 2022 - 09:21 PST
Identified
We've confirmed that this is an issue with Heroku. You can track that incident here: https://status.heroku.com/incidents/2402

We're seeing signs of recovery with our Metrics API, but the dashboard and the hubs continue to be down.
Posted Feb 24, 2022 - 08:55 PST
Update
We are continuing to investigate this issue.
Posted Feb 24, 2022 - 08:41 PST
Update
We are continuing to investigate. We have reason to believe Heroku (our upstream hosting provider) is having issues.
Posted Feb 24, 2022 - 08:39 PST
Investigating
We are investigating the issue.
Posted Feb 24, 2022 - 08:34 PST
This incident affected: ReadMe Hubs, Admin Dashboard, and Developer Metrics.